$re = '/host=(?<destinationIP>\d+\.\d+\.\d+\.\d+)/m';
$str = 'host=10.131.98.15:9997';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);