using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![ -.&,_'"":?!/])(?!.*[- &_'"":]$)(?!.*[-.#@&,:?!/]{2})[a-zA-Z0-9- .#@&,_'"":.?!/]+$";
string input = @"The Address Downtown";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}