# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[0]{1}[12345689]{1}[0-9]{1}[0-9]{7}$"
test_str = ("0112440767\n"
"0112575409\n"
"0112324846\n"
"0112434545\n"
"0112574651\n"
"0112421395\n"
"0112914215\n"
"0112447378\n"
"0112687141\n"
"0112431766\n"
"0114817240\n"
"0112810828\n"
"0112573296\n"
"0112580403\n"
"0112502437\n"
"0112449460\n"
"0112347856\n"
"0112421299\n"
"0112685633\n"
"0112575659\n"
"0112522545\n"
"0112330446\n"
"0112508512\n"
"0112692055\n"
"0112449631\n"
"0112336517\n"
"0112324924\n"
"0112335561\n"
"0112435306\n"
"0112436644\n"
"0112501030\n"
"0112522549\n"
"0112685773\n"
"0112686691\n"
"0112431174\n"
"0372238001\n"
"0112431405\n"
"0112432681\n"
"0112584173\n"
"0112584961\n"
"0112421464\n"
"0112320052\n"
"0112596747\n"
"0112324724\n"
"0112448612\n"
"0112433022\n"
"0112422473\n"
"0112338162\n"
"0112508100\n"
"0112438836\n"
"0112329161\n"
"0112440591\n"
"0112986417\n"
"0112435780\n"
"0372224138\n"
"0112431000\n"
"0112335836\n"
"0112301337\n"
"0112437936\n"
"0112334624\n"
"0112588884\n"
"0112432575\n"
"0112434683\n"
"0112589489\n"
"0372229141\n"
"0112503650\n"
"0112325225\n"
"0112330523\n"
"0112431531\n"
"0112434047\n"
"0112433495\n"
"0112325473\n"
"0112436311\n"
"0112323014\n"
"0112593973\n"
"0112582785\n"
"0112433286\n"
"0112502016\n"
"0112446699\n"
"0112816053")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.