$re = '/\d{12}(?:00[1-9]|0[1-9]\d|[1-9]\d\d)$/';
$str = '123412341234001';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);