#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)\b(?:Store Number|StreetA|City|State_id|Postal Code|Store Name|Phone Number|Tax Table \d|Artistree Vendor|Store Group|Store Zone number)+\b\s*[–,-]\s*(\w*.*)"
Local $sString = "FP Team," & @CRLF & _
"" & @CRLF & _
"Please install the Live database for store 1384. The updates have been completed." & @CRLF & _
"" & @CRLF & _
"• Store number - 1384" & @CRLF & _
"• StreetA – 1275 York Rd, Ste 21A" & @CRLF & _
"• City – Gettysburg" & @CRLF & _
"• State_id – PA" & @CRLF & _
"• Postal Code – 17325-7565" & @CRLF & _
"• Store Name – Gettysburg, PA" & @CRLF & _
"• Phone Number – (717) 420-8200" & @CRLF & _
"• Tax Rates" & @CRLF & _
" o Tax table 1 – 6.0000%" & @CRLF & _
" o Tax table 2 – 0.0000%" & @CRLF & _
" o Tax table 3 – 0.0000%" & @CRLF & _
" o Tax table 4 – 0.0000%" & @CRLF & _
" o Tax table 5 – N/A" & @CRLF & _
"• Artistree vendor – Kernersville" & @CRLF & _
"• Store Group – US.201308" & @CRLF & _
"• Store Zone number – 2030"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")