#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:25[0-5]|(?:2[0-4]|1[0-9]|[1-9]|)[0-9])(?:\.(?!$)|$)){4}"
Local $sString = "validates:" & @CRLF & _
" 0.0.0.0:0" & @CRLF & _
" 255.0.0.0" & @CRLF & _
" 192.168.1.0:8080" & @CRLF & _
"does not validate:" & @CRLF & _
" 192.168.0.0/24" & @CRLF & _
" 192.168..1" & @CRLF & _
" 192.168.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")