$re = '/0*(\d+\.0?\d*?)0*(\D|$)/m';
$str = '7.315200
21.234400
20.450000
0.000000
90.0
0.0
0.500000
1.000000
20.95
5.3
0.00001
7.30
0.86603
0.0234501231000
100.0
000123.000456000
010
00102030.405060
00001.0';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;