$re = '/^(?:(?:25[0-5]|2[0-4]\d|1?\d{1,2})(?:\.(?!$)|$)){4}$/m';
$str = 'validates:
192.68.35.35
0.0.0.0
255.0.0.0
192.168.1.0
192.168.0.1
255.255.255.0
1.1.1.1
255.255.255.255
249.249.249.249
200.200.200.200
199.199.199.199
100.100.100.100
99.99.99.99
0.0.0.0
9.9.9.9
10.10.10.10
99.99.99.99
100.100.100.100
109.109.109.109
110.110.110.110
199.199.199.199
200.200.200.200
249.249.249.249
250.250.250.250
255.255.255.255
01.01.01.01
09.09.09.09
192.168.0.1
255.255.255.255
1.1.1.1
should not validate:
256.256.256.260
192.168.0.0/24
192.168..1
192.168.1
1
1.
1.1
1.1.
1.1.1
1.1.1.
1.1.1.1.
1.1.1.1.1
.1.1.1.1
1.0.0.1.0
010.1.1.1
123456
123123123123
.127.0.0.1
192.168.0.1000
300.168.0.1
192.168.0.1.
192.168.0..1
192.16a8.0.1
123.234.345
123.123
11.11.1
.192.168.0.1
.192.168.0.
.192.168.0
....
.......
........';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);