# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:(25[0-5]|2[0-4][0-9]|[01]?[0-9]?[0-9])\.(25[0-5]|2[0-4][0-9]|[01]?[0-9]?[0-9])\.(25[0-5]|2[0-4][0-9]|[01]?[0-9]?[0-9])\.(25[0-5]|2[0-4][0-9]|[01]?[0-9]?[0-9]))|\:(\d*)\b"
test_str = ("<http>1.0.170.50:80</http>\n"
"<http>1.1.189.58:8080</http>\n"
"<http>1.1.220.100:8080</http>\n"
"<http>1.2.252.65:8080</http>\n"
"<http>1.20.166.142:8080</http>\n"
"<http>1.32.59.217:47045</http>\n"
"<http>1.179.136.98:8080</http>\n"
"<http>1.179.144.41:8080</http>\n"
"<http>1.179.148.9:36476</http>\n"
"<http>1.186.85.38:1111</http>\n"
"<http>3.20.236.208:49205</http>\n"
"<http>3.215.177.148:49205</http>\n"
"<http>5.16.0.97:1256</http>\n"
"<http>5.16.0.174:8080</http>\n"
"<http>5.16.0.180:8080</http>\n"
"<http>5.16.1.17:8080</http>\n"
"<http>5.22.196.30:8080</http>\n"
"<http>5.44.62.166:8080</http>\n"
"<http>5.58.33.187:55507</http>\n"
"<http>5.59.145.129:8080</http>\n"
"<http>5.135.176.161:10000</http>\n"
"<http>5.153.234.91:3128</http>\n"
"<http>5.180.130.90:80</http>\n"
"<http>5.180.130.91:8080</http>\n"
"<http>5.188.136.52:8080</http>\n"
"<http>5.202.191.226:80</http>\n"
"<http>8.242.207.202:8080</http>\n"
"<http>12.88.29.66:9080</http>\n"
"<http>12.144.254.185:9080</http>\n"
"<http>12.218.209.130:13326</http>\n"
"<http>14.102.13.161:8080</http>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.