// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\+\d{1})?[\s.-]?\(?\d{3}\)?[\s.-]?\d{3}[\s-.]?\d{4}").unwrap();
let string = "Match on a phone number in ANY standard phone number format.
PHONE: 210 210-2100 123123a1
+1(210)-210.2100-KYLEV
210 210-2100
+1(210)-210.2100";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}