re = /^(\+\d{1,2}\s)?\(?\d{3}\)?[\s.-]?\d{3}[\s.-]?\d{4}$/
str = '+1 (134) 564-3524'
# Print the match result
str.match(re) do |match|
puts match.to_s
end