$re = '/(.*)@amu\.edu\.pl \1 /';
$str = 'jassem@amu.edu.pl jassem';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);