$re = '/^([a-z][a-z0-9_.]+@([a-z0-9-]+\.)+[a-z]{2,6}(,\s{0,1}){0,1})+$/';
$str = 'mail1@example.com, mail2@example.net, mail3@domain-name.co.uk, mail_4@example.fr, mail.5@example.org';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);