#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(I1|I2|I3|I4|I5|I6|II|III|IV|V|VI|VII|VIII|IX|X|XI|XII|XIII|XIV|XV|XVI|XVII|XVIII|XIX)$"
Local $sString = "I1" & @CRLF & _
"I2" & @CRLF & _
"I3" & @CRLF & _
"I4" & @CRLF & _
"I5" & @CRLF & _
"I6" & @CRLF & _
"II" & @CRLF & _
"III" & @CRLF & _
"IV" & @CRLF & _
"V" & @CRLF & _
"VI" & @CRLF & _
"VII" & @CRLF & _
"VIII" & @CRLF & _
"IX" & @CRLF & _
"X" & @CRLF & _
"XI" & @CRLF & _
"XII" & @CRLF & _
"XIII" & @CRLF & _
"XIV" & @CRLF & _
"XV" & @CRLF & _
"XVI" & @CRLF & _
"XVII" & @CRLF & _
"XVIII" & @CRLF & _
"XIX"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")