const regex = /^(0?[0-9]?[0-9]|1[01][0-9]|12[0-7])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0?[0-9]?[0-9]|1[01][0-9]|12[0-7])$', 'gm')
const str = `<--! select 0 or 000..127 sequences -->
0
00
000
001
002
004
010
011
021
100
101
110
115
120
125
127
135
139
141
201
222
230
245
247
250
254 sgnlfsf
2340
345
255
853
999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}