using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\ {0,1}([A-Za-z]*)\t([0-9]*)";
string substitution = @"\t\1";
string input = @"74572: Blaufelden
Alkertshausen
Billingsbach
Blaubach
Blaufelden
Brüchlingen
Ehringshausen
Emmertsbühl
Engelhardshausen
Erpfersweiler
Gammesfeld
Herrentierbach
Heufelwinden
Kottmannsweiler
Lentersweiler
Metzholz
Mittelbach
Naicha
Niederweiler
Raboldshausen
Saalbach
Simmetshausen
Wiesenbach
Wittenweiler
74575: Schrozberg
Bartenstein
Böhmweiler
Bossendorf
Bovenzenweiler
Eichholz
Eichswiesen
Enzenweiler
Ettenhausen
Funkstatt
Ganertshausen
Gemmhagen
Großbärenweiler
Gütbach
Hechelein
Heiligenbronn
Heuchlingen
Hirschbronn
Hornungshof
Hummertsweiler
Kälberbach
Kleinbärenweiler
Klopfhof
Könbronn
Krailshausen
Kreuzfeld
Leuzendorf
Lindlein
Mäusberg
Obereichenrot
Reichertswiesen
Reupoldsrot
Riedbach
Schmalfelden
Schrozberg
Sigisweiler
Speckheim
Spielbach
Spindelbach
Standorf
Untereichenrot
Wittmersklingen
Wolfskreut
Zell
74585: Rot am See
Beimbach
Bemberg
Brettenfeld
Brettheim
Hausen
Hegenau
Herbertshausen
Heroldhausen
Hertershofen
Hilgartshausen
Kleinansbach
Kleinbrettheim
Kühnhard
Lenkerstetten
Musdorf
Niederwinden
Oberndorf
Oberwinden
Reinsbürg
Reubach
Rot am See
Weikersholz
74599: Wallhausen
Asbach
Hengstfeld
Limbach
Michelbach an der Lücke
Roßbürg
Schainbach
Schönbronn
Wallhausen
91471: Illesheim
Illesheim 91471
Sontheim 91471
Urfersheim 91471
Westheim 91471
91541: Rothenburg
Bettenfeld
Burgstall
Detwang
Dürrenhof
Hemmendorf ob der Tauber
Herrnwinden
Leuzenbronn ob der Tauber
Reusch
Schandhof
Schnepfendorf ob der Tauber
Steinbach
Vorbach ob der Tauber
91583: Schillingsfürst
Altengreuth
Bersbronn
Faulenberg
Leipoldsberg
Neureuth
Neuweiler
Schillingsfürst
Schorndorf
Stilzendorf
Wittum
Wohnbach
Ziegelhütte
91583: Diebach
Bellershausen
Diebach
Oberoestheim
Unteroestheim
Wolfsau
91587: Adelshofen
Adelshofen
Gickelhausen
Großharbach
Haardt
Neustett
Ruckertshofen
Tauberscheckenbach
Tauberzell
91592:
Berbersbach am Wald
Gastenfelden
Hagenau am Wald
Morlitzwinden am Wald
Schönbronn
Schweikartswinden
Sengelhof
Traisdorf
91593: Burgbernheim
Buchheim
Burgbernheim
Hilpertshof
Hochbach
Pfaffenhofen
Schwebheim
91598: Colmberg
Auerbach
Bieg am Wald
Binzwangen
Colmberg
Häslabronn
Kurzendorf
Meuchlein
Oberfelden
Oberhegenau
Poppenbach
Unterfelden
Unterhegenau
91601: Dombühl
Baimhofen
Binsenweiler
Bortenberg
Dombühl
Höfen
Kloster Sulz
Ziegelhaus
91605: Gallmersgarten
Bergtshofen 91605
Gallmersgarten 91605
Mörlbach 91605
Steinach an der Ens 91605
Steinach bei Rothenburg ob der Tauber 91605
91607: Gebsattel
Bockenfeld
Eckartshof
Gebsattel
Kirnberg
Pleikartshof
Rödersdorf
Speierhof
Wildenhof
91608: Geslau
Aidenau
Dornhausen
Geslau
Gunzendorf
Hürbel
Kreuth
Lauterbach
Oberbreitenau
Oberndorf
Reinswinden
Schwabsroth
Steinach am Wald
Stettberg
Unterbreitenau
91610: Insingen
Insingen 91610
Leidenberg 91610
Leuzhof 91610
Lohr 91610
Lohrbach 91610
91613: Marktbergel
Ermetzhof 91613
Marktbergel 91613
Ottenhofen 91613
91616: Neusitz
Erlbach ob der Tauber
Horabach ob der Tauber
Neusitz
Schweinsdorf ob der Tauber
Södelbronn ob der Tauber
Wachsenberg ob der Tauber
91620: Ohrenbach
Gailshofen
Gumpelshofen
Habelsee
Oberscheckenbach
Ohrenbach
Reichardsroth
91628: Steinsfeld
Bettwar
Chausseehaus
Ellwingshofen
Endsee
Gattenhofen
Hartershofen
Reichelshofen
Steinsfeld
Urphershofen
91631: Wettringen
Grüb
Obergailnau
Reichenbach
Seemühle
Taubermühle
Untergailnau
Wettringen
91635: Windelsbach
Birkach
Burghausen
Cadolzhofen
Hornau
Linden bei Rothenburg ob der Tauber
Nordenberg bei Rothenburg ob der Tauber
Preuntsfelden
Windelsbach
91637: Wörnitz
Arzbach
Bastenau
Bottenweiler
Erzberg
Harlang
Mittelstetten
Oberwörnitz
Walkersdorf
Wörnitz
97215: Uffenheim
Brackenlohr
Custenlohr
Kleinharbach
Langensteinach
Rudolzhofen
Uffenheim
Uttenhofen
Wallmersbach
Welbhausen
97215: Weigenheim
Geckenheim 97215
Reusch bei Würzburg 97215
Weigenheim 97215
97215: Simmershofen
Adelhofen
Auernhofen
Equarhofen
Hohlach
Simmershofen
Walkershofen
97993: Creglingen
Archshofen
Blumweiler
Craintal
Creglingen
Erdbach
Finsterlohr
Frauental
Freudenbach
Lichtel
Lohrhof
Münster
Niederrimbach
Niedersteinach
Oberrimbach
Reinsbronn
Reutsachsen
Schirmbach
Schmerbach
Schön
Schonach
Schwarzenbronn
Sechselbach
Seldeneck
Waldmannshofen
Weidenhof
Weiler
Wolfsbuch
97996: Niederstetten
Adolzhausen
Dunzendorf
Ebertsbronn
Eichhof
Ermershausen
Hachtel
Heimberg
Herrenzimmern
Niederstetten
Oberstetten
Pfitzingen
Rinderfeld
Rüsselhausen
Sichertshausen
Streichental
Vorbachzimmern
Wermutshausen
Wildentierbach
Wolkersfelden
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}