re = /^\d+((,\d)?(-(\d+)?(,\d)?)?)?$/m
str = '13,4
5,66876876
13,4-15,6
4-5
5
45
34,534
13,7-14
14-15,6
14-15,67
1,236
14,5-15
15-16,5
4,5-16,76
100,4
100,45
100,45-100,4
100,4-100,54
100,5-123323,5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end