# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:|(https?:\/\/)?(|www)[.]?)(?:t|telegram)\.(?:me|dog)/(joinchat/|\+)?([\w-]+)"
test_str = ("https://www.t.me/joinchat/I5antRHvea8ohaU7_RsYYQ\n"
"https://www.telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ\n"
"http://t.me/joinchat/I5antRHvea8ohaU7_RsYYQ\n"
"http://telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ\n"
"www.t.me/joinchat/I5antRHvea8ohaU7_RsYYQ\n"
"www.telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ\n"
"t.me/joinchat/I5antRHvea8ohaU7_RsYYQ\n"
"telegram.me/joinchat/I5antRHvea8ohaU7_RsYYQ\n"
"t.me/I5antRHvea8ohaU7_RsYYQ\n"
"t.dog/I5antRHvea8ohaU7_RsYYQ\n"
"https://t.dog/I5antRHvea8ohaU7_RsYYQ\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.