re = /a?a?a?a?a?a?a?a?a?a?a?a?a?a?a?a?a?a?a?a?aaaaaaaaaaaaaaaaaaaa/
str = 'aaaaaaaaaaaaaaaaaaaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end