re = /([0-9]+)\.([0-9]+)\.([0-9]+)(?:-([0-9A-Za-z-]+(?:\.[0-9A-Za-z-]+)*))?(?:\+[0-9A-Za-z-]+)?/m
str = '1.45.125-prod'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end