re = /^([a-zA-Z0-9.!#$%&’*+\/=?^_`{|}~-]{1,64}@([a-zA-Z0-9-]+.[a-zA-Z0-9-]{2,}){1,255}){1,320}$/
str = 'qwertyuiopqwertyuiopqwertyuiopqwertyuiopqwertyuiopqwertyuiopqwer@b.cc'
# Print the match result
str.match(re) do |match|
puts match.to_s
end