$re = '/^(https?:\/\/)?(www\.)?([\w\.]+)(\/[\.\/\w]*)?(\?[\w=&]+)?/mi';
$str = 'httPs://wwW.Auth.google1.com/?fdgjhfd
htPs://wwW.Auth.google1.com/?fdgjhfd
httPs:/wwW.Auth.google1.com/?fdgjhfd
httPs://wW.Auth.google1.co?
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);