#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((https|http):\/?\/?)?(?<bucket>[a-z\-]*)(\.s3\.)(?<server>[a-z\-\d]*)(\.amazonaws\.com\/)(?<key>[^?\s]*)(\?)?(?<extra>\??.*)"
Local $sString = "https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/2iw99y1.jpg" & @CRLF & _
"https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/advisor/anand%40pulse360.com/img/signature.png" & @CRLF & _
"https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/company_logo.jpg" & @CRLF & _
"https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/Entrega%202%20-%20Punto%206%20.png" & @CRLF & _
"https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/tb.jpg" & @CRLF & _
"https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/advisor/santiago.persico%40teracloud.io/img/signature.png" & @CRLF & _
"https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/Lyrics.jpg" & @CRLF & _
"https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/face2.jpg" & @CRLF & _
"https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/arriba%20small%20compressed.jpg" & @CRLF & _
"https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/vepPagado.pdf" & @CRLF & _
"https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/Flyster---300px.jpg" & @CRLF & _
"https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/Skull.png?asd=asd" & @CRLF & _
"https://practice-assets-test-wealthbox-dev.s3.us-west-2.amazonaws.com/common/img/2iw99y1.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")