// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{1,2}\/\d{1,2}\/\d{1,4}\s+R[$]((?:\d+\.)?\d+\,\d+)").unwrap();
let string = " 18/01/2021 R$37.187,30";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}