// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[A-Z][a-z]+\b\s+\b[A-Z][a-z]+\b").unwrap();
let string = "54. Mikhail Stepanovich ZUSKO
(Михаил Степанович ЗУСЬКО)
Function: Russian military leader – Lieutenant- General
Chief of staff of the “West” grouping
Former Commander of the 58th Combined Arms Army of the Southern Military District
DOB: 24.5.1972
POB: Vetly, Volyn region, former Ukrainian SSR (now Ukraine)
Nationality: Russian
Gender: male
Associated entities: Ministry of Defence of the Russian Federation
55. Mikhail Yuryevich TEPLINSKIY
(Михаил Юрьевич ТЕПЛИНСКИЙ)
Function: Russian military leader – Colonel-General
Commander of Airborne Forces of the Armed Forces of the Russian Federation
DOB: 9.1.1969
POB: Mospino, Donetsk oblast, former Ukrainian SSR (now Ukraine)
Nationality: Russian
Gender: male
Associated entities: Ministry of Defence of the Russian Federation
56. Nikolay Mikhailovich PARSHIN
(Николай Михайлович ПАРШИН)
Function: Russian military leader – Lieutenant- General
Head of the Main Rocket and Artillery Directorate of the Ministry of Defense of the Russian Federation
DOB: 20.12.1962
POB: The village of Mordovskoye- Kolomasovo, former Mordovian ASSR (now Russian Federation)
Nationality: Russian
Gender: male
Associated entities: Ministry of Defence of the Russian Federation
57. Oleg Yurievich TSOKOV
(Олег Юрьевич ЦОКОВ)
Function: Russian military leader – Major-General
Commander of the 144th Motor Rifle Division of the 20th Combined Arms Army of the Armed Forces of the Russian Federation
DOB: 23.9.1971
POB: former USSR (now Russian Federation)
Nationality: Russian
Gender: male
Associated entities: Ministry of Defence of the Russian Federation
58. Ramil Rakhmatulovich IBATULLIN
(Рамиль Рахматуллович ИБАТУЛЛИН)
Function: Russian military leader – Major-General
Commander of the 90th Guards Tank Division
DOB: 22.10.1976
POB: Bagishevo, Apastovsky District, Tatarstan, former USSR (now Russian Federation)
Nationality: Russian
Gender: male
Associated entities: Ministry of Defence of the Russian Federation
59. Sergey Viktorovich KARAKAEV
(Сергей Викторович КАРАКАЕВ)
Function: Russian military leader – Colonel-General
Commander of the Strategic Missile Forces
DOB: 4.6.1961
POB: The village of Ivano-Slyusarevka, Krasnodar Territory, former USSR (now Russian Federation)
Nationality: Russian
Gender: male
Associated entities: Ministry of Defence of the Russian Federation
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}