#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(PO BOX|BOX)+\s*[A-Z]?[0-9]+[A-Z]*\s.*$"
Local $sString = "BOX ELDER CT" & @CRLF & _
"PO BOX 111 " & @CRLF & _
"PO BOX 191 " & @CRLF & _
"39TH ST" & @CRLF & _
"6TH ST" & @CRLF & _
"4TH AVE" & @CRLF & _
"5TH AVE" & @CRLF & _
"5TH ST" & @CRLF & _
"2ND AVE" & @CRLF & _
"15TH AVE" & @CRLF & _
"BOX ELDER DR" & @CRLF & _
"PO BOX 297 " & @CRLF & _
"PO BOX 42 " & @CRLF & _
"PO BOX 18 " & @CRLF & _
"PO BOX 16 " & @CRLF & _
"PO BOX 115A " & @CRLF & _
"PO BOX 245 " & @CRLF & _
"PO BOX 131 " & @CRLF & _
"PO BOX 254 " & @CRLF & _
"PO BOX 254 " & @CRLF & _
"PO BOX 49B " & @CRLF & _
"PO BOX 373 " & @CRLF & _
"PO BOX 178 " & @CRLF & _
"PO BOX 245 " & @CRLF & _
"PO BOX 51 " & @CRLF & _
"PO BOX 400 " & @CRLF & _
"PO BOX 25 " & @CRLF & _
"PO BOX 25 " & @CRLF & _
"PO BOX 7 " & @CRLF & _
"PO BOX 97 " & @CRLF & _
"PO BOX 363 " & @CRLF & _
"PO BOX 482 " & @CRLF & _
"PO BOX 24 " & @CRLF & _
"PO BOX 55 " & @CRLF & _
"PO BOX 204 " & @CRLF & _
"PO BOX 482 " & @CRLF & _
"PO BOX 331 " & @CRLF & _
"PO BOX 99 " & @CRLF & _
"PO BOX 204 " & @CRLF & _
"PO BOX 224C " & @CRLF & _
"BOX 246 " & @CRLF & _
"BOX 2005 " & @CRLF & _
"BOX 431 ATLAN & CLEV " & @CRLF & _
"BOX 384 " & @CRLF & _
"BOX 22 " & @CRLF & _
"BOX 247 " & @CRLF & _
"BOX 212 " & @CRLF & _
"BOX 85 " & @CRLF & _
"PO BOX 192 " & @CRLF & _
"PO BOX 192 " & @CRLF & _
"BOX 232 " & @CRLF & _
"BOX 28 " & @CRLF & _
"PO BOX A73 " & @CRLF & _
"PO BOX 53 " & @CRLF & _
"BOX 4 " & @CRLF & _
"PO BOX 266 " & @CRLF & _
"BOX 154 " & @CRLF & _
"BOX 261 " & @CRLF & _
"BOX 82 " & @CRLF & _
"BOX ELDER LN" & @CRLF & _
"BOX 101 " & @CRLF & _
"PO BOX 76 EAST MARKET "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")