#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<location>[A-Za-z]+)[-_][A-Z]{1,2}\d"
Local $sString = "BMD-R1" & @CRLF & _
"BMD-R2" & @CRLF & _
"BTN-R1" & @CRLF & _
"BTN-R1-SW" & @CRLF & _
"BTN-R2" & @CRLF & _
"BTN-R2-SW" & @CRLF & _
"CentralOCS-R1" & @CRLF & _
"CentralOCS-R1-SW" & @CRLF & _
"CentralOCS-R2" & @CRLF & _
"CentralOCS-R2-SW" & @CRLF & _
"CentralOCS-SW3" & @CRLF & _
"CentralOCS-SW4" & @CRLF & _
"CLJ-R1" & @CRLF & _
"CLJ-R2" & @CRLF & _
"CS-HPOV-MLS1" & @CRLF & _
"CS-HPOV-MLS2" & @CRLF & _
"CTN-R1" & @CRLF & _
"CTN-R2" & @CRLF & _
"EKV-OTC-MLS1" & @CRLF & _
"GOS-R1" & @CRLF & _
"GOS-R2" & @CRLF & _
"GVL-R1" & @CRLF & _
"GVL-R2" & @CRLF & _
"ING-R1" & @CRLF & _
"LAW-R1" & @CRLF & _
"LCS-R1" & @CRLF & _
"LCS-R2" & @CRLF & _
"LIV-R1" & @CRLF & _
"Mascot_R1" & @CRLF & _
"Mascot_R2" & @CRLF & _
"Mascot_SW1" & @CRLF & _
"Mascot_SW2" & @CRLF & _
"Mascot_SW3" & @CRLF & _
"MST-R1" & @CRLF & _
"MST-R2" & @CRLF & _
"MTV-R1" & @CRLF & _
"MTV-R2" & @CRLF & _
"OSS-FW1 (FO)" & @CRLF & _
"OSS-FW1 (Pri)" & @CRLF & _
"PEN-R1" & @CRLF & _
"PEN-R2" & @CRLF & _
"Pitt_R1" & @CRLF & _
"ROC-FW1" & @CRLF & _
"ROC-HPDM-SW1" & @CRLF & _
"ROC-PUB-MLS1" & @CRLF & _
"ROC-PUB-MLS2" & @CRLF & _
"ROC-RCS-SW " & @CRLF & _
"SM-ER-SW1 " & @CRLF & _
"SM-ER-SW2 " & @CRLF & _
"SM-FW1 (FO)" & @CRLF & _
"SM-FW1 (Pri)" & @CRLF & _
"SM-PUB-R1" & @CRLF & _
"SM-PUB-R1-SW" & @CRLF & _
"SM-PUB-R2" & @CRLF & _
"SM-PUB-R2-SW" & @CRLF & _
"SM-RCS-R1" & @CRLF & _
"SM-RCS-R2" & @CRLF & _
"SM-RCS-SW1" & @CRLF & _
"SM-RCS-SW2" & @CRLF & _
"ST-ER-SW1 " & @CRLF & _
"ST-ER-SW2 " & @CRLF & _
"ST-FW1 (FO)" & @CRLF & _
"ST-FW1 (Pri)" & @CRLF & _
"STM-R1" & @CRLF & _
"STM-R2" & @CRLF & _
"ST-OSS-MAIN-R1" & @CRLF & _
"ST-OSS-MAIN-R2" & @CRLF & _
"ST-OSS-PUB-R1" & @CRLF & _
"ST-OSS-PUB-R1-SW" & @CRLF & _
"ST-OSS-PUB-R2" & @CRLF & _
"ST-OSS-PUB-R2-SW" & @CRLF & _
"ST-PUB-MLS1" & @CRLF & _
"ST-PUB-MLS2" & @CRLF & _
"ST-PUB-R1" & @CRLF & _
"ST-PUB-R2" & @CRLF & _
"ST-RCS-R1" & @CRLF & _
"ST-RCS-R2" & @CRLF & _
"ST-RCS-SW1" & @CRLF & _
"ST-RCS-SW2" & @CRLF & _
"TES-SW1" & @CRLF & _
"Waterfall_SW1" & @CRLF & _
"Waterfall_SW2" & @CRLF & _
"Waterfall-R1" & @CRLF & _
"Waterfall-R2" & @CRLF & _
"WolloFW_R1" & @CRLF & _
"WolloFW_R2" & @CRLF & _
"WolloFW_SW" & @CRLF & _
"WYG-R1" & @CRLF & _
"WYG-R2" & @CRLF & _
"Wynyard_R1" & @CRLF & _
"Wynyard_R2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")