#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?P<Day1>\d{1,2})(?:\W*(?P<Month1>[A-Z][a-z]*\b))|(?:(?P<Month2>[A-Z][a-z]*\b)\W*)(?:(?P<Day2>\d{1,2})(?:\b|th|st|nd))?|(?P<Month3>\d{1,2})\W+(?P<Day3>\d{1,2})|(?P<Month4>\d{1,2}))?\W+?(?P<Year>\d{2,4}(?=$|;))"
Local $sString = "04/20/2009" & @CRLF & _
"04/20/09" & @CRLF & _
"4/20/09" & @CRLF & _
"4/3/09" & @CRLF & _
"Mar-20-2009" & @CRLF & _
"Mar 20, 2009" & @CRLF & _
"March 20, 2009" & @CRLF & _
"Mar. 20, 2009" & @CRLF & _
"Mar 20 2009;" & @CRLF & _
"20 Mar 2009" & @CRLF & _
"20 March 2009" & @CRLF & _
"20 Mar. 2009" & @CRLF & _
"20 March, 2009" & @CRLF & _
"Mar 20th, 2009" & @CRLF & _
"Mar 21st, 2009" & @CRLF & _
"Mar 22nd, 2009" & @CRLF & _
"Feb 2009" & @CRLF & _
"Sep 2009" & @CRLF & _
"Oct 2010" & @CRLF & _
"6/2008" & @CRLF & _
"12/2009" & @CRLF & _
"2009" & @CRLF & _
"2010"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")