$re = '/(?<=\,)\d{2}/';
$str = 'http://regexr.com
Welcome to RegExr v2.1 by gskinner.com, proudly hosted by Media Temple!
Edit the Expression & Text to see matches. Roll over – matches – or the expression for details. Undo mistakes with cmd-z. Save Favorites & Share $33 expressions with «friends or the Community. Explore your results with Tools. A full Reference & Help is available $2 in the Library, or watch the video Tutorial.
année 201, années 1969 à 1974, – anné 2015, mois 2013
Voici un -deuxième- paragraphe, avec – ÉT “retour” « régulier ».
Une clause clause inefficace suivi d’une autre clause.
La suite du texte se — poursuit toujours — normalement.
Voici un autre paragraphe avec un retour forcé (shift return).
Nous verrons comment les GREP saisiront cette donnée.
Les GREPs sont intégrés dans ces 2 applications — InDesign et Dreamweaver!
InDesign,InDesign 2.0, “InDesign CS” and InDesign CS2
The quick brown fox jumps up and down.
abc abc abc abc
BONJOUR SOLEIL.
Tot, tot, Toto, toto, totoo, totoooo, tatoo, tato, teratatotinotto
• $22.999, 23,99$, 19.99 $
$2.99, 22,99$, 2,99$, 2,99 $
2.53%, 20%
1.89L, 1,89 L — 2 pour 1$
514-123-4567
• h4N 1X7
• h8t
• h4N1X72 Ajout code postal
• h8T
mot à trouver
Charles ixv
1/3, 234/56
12h22, 12:00, 12am, 12 pm, 11h30 am, 8 PM, 6H15, 08:00, 6.00 pm
année 2017, années 1970 à 1974, anné 2016, mois 2014
22/11/2016, 01-08-2017, 01|02|2015, 20.12.2014, 2/3/2012
Sample text for testing:
SAMPLE
abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ
0123456789 _+-.,!@#$%^&*();\\/|<>”’
12345 -98.7 3.141 .6180 9,000 +42
1234 - 5678, 1234 - 1234
3oF, -10oC
555.123.4567 +1-(800)-555-2468
(123)-(456)-(7890)
(xxx (xxx) xxxxx (xx) xxx)
foo@demo.net bar.ba@test.co.uk
good4you@yummy.com
somebody@somewhere.ca, another.somebody@coucouland.com
www.demo.com http://foo.co.uk/
http://regexr.com/foo.html?q=bar
https://mediatemple.netx
76 g ou/or 85 g
22,99 ch./ ea.
22.99
222,22
2,222
22,222 22,
,11,
22,22$
22,22 $
195 ml, 273 ml ou/or 198 g
1 $
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);