import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(?:(?<!\\.)\\b|\\.)){4}";
final String string = "#Ejemplos de codigo fuente del lenguaje de programacion Ruby\n\n"
+ "#Aritmetica basica\n"
+ "resultado='5 * (12 - 8) + -15'\n"
+ "puts resultado\n"
+ "puts 98 + (59872 / (13 * 8)) * -52\n\n"
+ "#Textos\n"
+ "puts \"Hola, mundo!\"\n"
+ "puts \"\"\n"
+ "puts \"Adiós.\"\n"
+ "puts \"Me gusta\" + \"el pastel de manzana.\"\n"
+ "puts \"Mi IP es: 192.168.9.10\"\n"
+ "puts \"ragustin726@gmail.com\"\n"
+ "puts \"https://www.facebook.com\"\n"
+ "puts \"31/01/2021/\"\n\n"
+ "277.893.21.2\n\n"
+ "#Variables\n"
+ "myString = '...puedes decir eso de nuevo...'\n"
+ "puts myString\n"
+ "name = 'Patricia Rosanna Jessica Mildred Oppenheimer'\n"
+ "ip= 10.0.0.1\n"
+ "correo='roberto_840@hotmail.com'\n"
+ "direccion='https://www.google.com'\n"
+ "fecha = '19/07/2001'\n\n"
+ "#Concatenaciones\n"
+ "puts 'Me llamo ' + name + '.'\n"
+ "puts 'Wow! \"' + name + '\" es un nombre realmente largo!'\n"
+ "composer1 = 'Mozart'\n"
+ "puts composer1 + ' fue \"el amo\", en su día.'\n"
+ "composer = 'Beethoven'\n"
+ "puts 'Pero yo prefiero a ' + composer1 + ', personalmente.'\n\n"
+ "#Conversiones\n"
+ "var1 = 2\n"
+ "var2 = '5'\n"
+ "puts var1.to_s + var2\n"
+ "var1 = 2\n"
+ "var2 = '5'\n"
+ "puts var1.to_s + var2\n"
+ "puts var1 + var2.to_i\n\n"
+ "#Condicionales \n"
+ "puts 1 > 2\n"
+ "puts 1 < 2\n"
+ "puts 5 >= 5\n"
+ "puts 5 <= 4\n"
+ "puts 1 == 1\n"
+ "puts 2 != 1\n"
+ "puts 'gato' < 'perro'\n\n"
+ "#Ramificaciones\n"
+ "puts 'Hola, y bienvenido a la clase de 7mo año.'\n"
+ "puts 'Me llamo Mrs. Gabbard. ¿Tú nombre es...?'\n"
+ "nombre = gets.chomp\n\n"
+ "if nombre == nombre.capitalize\n"
+ " puts 'Por favor, toma asiento ' + nombre + '.'\n"
+ "else\n"
+ " puts '¿' + nombre + '? Quieres decir ' + nombre.capitalize + ', ¿cierto?'\n"
+ " puts '¿No sabes escribir tu propio nombre?'\n"
+ " respuesta = gets.chomp\n\n"
+ " if respuesta.downcase == 'si'\n"
+ " puts '¡Hum! Bueno, ¡siéntese!'\n"
+ " else\n"
+ " puts '¡SALGA DEL SALON!'\n"
+ " end\n"
+ "end\n\n"
+ "#Bucles\n"
+ "comando = ''\n"
+ "while comando != 'adios'\n"
+ " puts comando\n"
+ " comando = gets.chomp\n"
+ "end\n"
+ "puts '¡Vuelve pronto!'\n\n"
+ "#Operadores logicos\n"
+ "edad=18\n"
+ "sexo=\"Mujer\"\n"
+ "ocupacion=\"Estudiante\"\n"
+ "if edad>=18 and sexo==\"Mujer\" and ocupacion=\"Estudiante\"\n"
+ " puts \"Mujer mayor de edad estudiante\"\n"
+ "end\n\n"
+ "edad=18\n"
+ "if edad>=18 or edad<=25\n"
+ " puts \"Tu edad esta entre los 18 y 25 años\"\n"
+ "end\n\n"
+ "#Modulos y potencias\n"
+ "puts 5**2\n"
+ "puts 5**0.5\n"
+ "puts 7/3\n"
+ "puts 7%3\n"
+ "puts 365%7\n\n"
+ "#Lectura de archivos\n"
+ "content1 = File.read(\"imagen.jpg\") # lee el archivo\n"
+ "content2 = File.read(\"contenido.png\")\n"
+ "lines = content.split(\"\\n\") # divide el contenido en líneas\n\n"
+ "# recorre las líneas y las imprime\n"
+ "lines.each do |line|\n"
+ " puts line\n"
+ "end";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}