$re = '/^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9]).{8,}$/m';
$str = 'Hey123
helloclass123
HELLOCLASS123
HELLOCLASS
HelloClass123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);