$re = '/(?=.*[0-9])(?=.*[a-zA-Z]).*/m';
$str = '^4_*!:%t`~
^t_*!:%4`~
^4_*!:%`~
^_*!:%t`~
^t_*!:%`~
^_*!:%4`~
^_*!:%`~';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);