$re = '/\w*ab\w*|(\w*b\w*)/';
$str = 'fdfdfsdfdsfdsfd
abcd
ba
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);