use strict;
my $str = 'http://website.host21.ru/contacts?p1=2&p2=3
website.host21.ru/contacts/
https://host1.host21.ru:80/contacts/
http://localhost:5372';
my $regex = qr/^(?:(?'scheme'http[s]?):\/\/)?(?'host'[a-z0-9_\-.]+)(?:\:(?'port'[0-9]+))?(?'path'\/[^\?\s]*)?(?:\?(?'query'\S+))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}