package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)a{,3}`)
var str = `shahrukh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}