const regex = /^[1-9]{1}$|^[1-3]{1}[0-9]{1}$|^4{1}[0-5]{1}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1-9]{1}$|^[1-3]{1}[0-9]{1}$|^4{1}[0-5]{1}$', 'gm')
const str = `1
2
74
45
46
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}