#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<Buyer>[\s\S]+?<UserID>([^<]+)<\/UserID>"
Local $sString = "<?xml version="1.0" encoding="UTF-8"?>" & @CRLF & _
"<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">" & @CRLF & _
" <soapenv:Header>" & @CRLF & _
" <ebl:RequesterCredentials soapenv:mustUnderstand="0" xmlns:ebl="urn:ebay:apis:eBLBaseComponents" xmlns:ns="urn:ebay:apis:eBLBaseComponents">" & @CRLF & _
" <ebl:NotificationSignature xmlns:ebl="urn:ebay:apis:eBLBaseComponents">eVkp8yKqOGGl6b03ezOglA==</ebl:NotificationSignature>" & @CRLF & _
" </ebl:RequesterCredentials>" & @CRLF & _
" </soapenv:Header>" & @CRLF & _
" <soapenv:Body>" & @CRLF & _
" <GetItemTransactionsResponse xmlns="urn:ebay:apis:eBLBaseComponents">" & @CRLF & _
" <Timestamp>2018-11-06T07:14:02.377Z</Timestamp>" & @CRLF & _
" <Ack>Success</Ack>" & @CRLF & _
" <CorrelationID>1495072616792</CorrelationID>" & @CRLF & _
" <Version>1083</Version>" & @CRLF & _
" <Build>E1083_INTL_APIXO_18856824_R1</Build>" & @CRLF & _
" <NotificationEventName>AuctionCheckoutComplete</NotificationEventName>" & @CRLF & _
" <RecipientUserID>oz.sunshine</RecipientUserID>" & @CRLF & _
" <EIASToken>nY+sHZ2PrBmdj6wVnY+sEZ2PrA2dj6AElYKhC5eKqQWdj6x9nY+seQ==</EIASToken>" & @CRLF & _
" <PaginationResult>" & @CRLF & _
" <TotalNumberOfPages>1</TotalNumberOfPages>" & @CRLF & _
" <TotalNumberOfEntries>1</TotalNumberOfEntries>" & @CRLF & _
" </PaginationResult>" & @CRLF & _
" <HasMoreTransactions>false</HasMoreTransactions>" & @CRLF & _
" <TransactionsPerPage>100</TransactionsPerPage>" & @CRLF & _
" <PageNumber>1</PageNumber>" & @CRLF & _
" <ReturnedTransactionCountActual>1</ReturnedTransactionCountActual>" & @CRLF & _
" <Item>" & @CRLF & _
" <ApplicationData>ic6d9i844054605431312608388a</ApplicationData>" & @CRLF & _
" <AutoPay>false</AutoPay>" & @CRLF & _
" <BuyItNowPrice currencyID="AUD">0.0</BuyItNowPrice>" & @CRLF & _
" <Currency>AUD</Currency>" & @CRLF & _
" <ItemID>222203266767</ItemID>" & @CRLF & _
" <ListingDetails>" & @CRLF & _
" <StartTime>2016-07-29T13:10:54.000Z</StartTime>" & @CRLF & _
" <EndTime>2018-11-16T13:10:54.000Z</EndTime>" & @CRLF & _
" <ViewItemURL>http://cgi.ebay.com.au/ws/eBayISAPI.dll?ViewItem&Item=222203266767</ViewItemURL>" & @CRLF & _
" <ViewItemURLForNaturalSearch>http://cgi.ebay.com.au/2018-NEW-Toilet-Bidet-Seat-Spray-Hygeian-Water-Clean-Unisex-Bathroom-Shattaf-AU?item=222203266767&category=0&cmd=ViewItem</ViewItemURLForNaturalSearch>" & @CRLF & _
" </ListingDetails>" & @CRLF & _
" <ListingType>FixedPriceItem</ListingType>" & @CRLF & _
" <PaymentMethods>MoneyXferAccepted</PaymentMethods>" & @CRLF & _
" <PaymentMethods>PayPal</PaymentMethods>" & @CRLF & _
" <PaymentMethods>VisaMC</PaymentMethods>" & @CRLF & _
" <PrimaryCategory>" & @CRLF & _
" <CategoryID>101405</CategoryID>" & @CRLF & _
" </PrimaryCategory>" & @CRLF & _
" <PrivateListing>true</PrivateListing>" & @CRLF & _
" <Quantity>2142</Quantity>" & @CRLF & _
" <SecondaryCategory>" & @CRLF & _
" <CategoryID>0</CategoryID>" & @CRLF & _
" </SecondaryCategory>" & @CRLF & _
" <Seller>" & @CRLF & _
" <AboutMePage>false</AboutMePage>" & @CRLF & _
" <EIASToken>nY+sHZ2PrBmdj6wVnY+sEZ2PrA2dj6AElYKhC5eKqQWdj6x9nY+seQ==</EIASToken>" & @CRLF & _
" <Email>oz-sunshine@elifeonline.com.au</Email>" & @CRLF & _
" <FeedbackScore>17305</FeedbackScore>" & @CRLF & _
" <PositiveFeedbackPercent>99.5</PositiveFeedbackPercent>" & @CRLF & _
" <FeedbackPrivate>false</FeedbackPrivate>" & @CRLF & _
" <FeedbackRatingStar>YellowShooting</FeedbackRatingStar>" & @CRLF & _
" <IDVerified>false</IDVerified>" & @CRLF & _
" <eBayGoodStanding>true</eBayGoodStanding>" & @CRLF & _
" <NewUser>false</NewUser>" & @CRLF & _
" <RegistrationDate>2011-02-27T09:05:29.000Z</RegistrationDate>" & @CRLF & _
" <Site>Australia</Site>" & @CRLF & _
" <Status>Confirmed</Status>" & @CRLF & _
" <UserID>oz.sunshine</UserID>" & @CRLF & _
" <UserIDChanged>false</UserIDChanged>" & @CRLF & _
" <UserIDLastChanged>2016-03-01T00:38:25.000Z</UserIDLastChanged>" & @CRLF & _
" <VATStatus>VATExempt</VATStatus>" & @CRLF & _
" <SellerInfo>" & @CRLF & _
" <AllowPaymentEdit>true</AllowPaymentEdit>" & @CRLF & _
" <CheckoutEnabled>true</CheckoutEnabled>" & @CRLF & _
" <CIPBankAccountStored>false</CIPBankAccountStored>" & @CRLF & _
" <GoodStanding>true</GoodStanding>" & @CRLF & _
" <LiveAuctionAuthorized>false</LiveAuctionAuthorized>" & @CRLF & _
" <MerchandizingPref>OptIn</MerchandizingPref>" & @CRLF & _
" <QualifiesForB2BVAT>false</QualifiesForB2BVAT>" & @CRLF & _
" <StoreOwner>true</StoreOwner>" & @CRLF & _
" <StoreURL>http://stores.ebay.com.au/shopelife</StoreURL>" & @CRLF & _
" <SafePaymentExempt>false</SafePaymentExempt>" & @CRLF & _
" <TopRatedSeller>true</TopRatedSeller>" & @CRLF & _
" </SellerInfo>" & @CRLF & _
" </Seller>" & @CRLF & _
" <SellingStatus>" & @CRLF & _
" <ConvertedCurrentPrice currencyID="AUD">24.74</ConvertedCurrentPrice>" & @CRLF & _
" <CurrentPrice currencyID="AUD">24.74</CurrentPrice>" & @CRLF & _
" <QuantitySold>2074</QuantitySold>" & @CRLF & _
" <ListingStatus>Active</ListingStatus>" & @CRLF & _
" </SellingStatus>" & @CRLF & _
" <Site>Australia</Site>" & @CRLF & _
" <StartPrice currencyID="AUD">24.74</StartPrice>" & @CRLF & _
" <Title>2018 NEW Toilet Bidet Seat Spray Hygeian Water Clean Unisex Bathroom Shattaf AU</Title>" & @CRLF & _
" <GetItFast>false</GetItFast>" & @CRLF & _
" <SKU>FAZ0181008AU</SKU>" & @CRLF & _
" <IntegratedMerchantCreditCardEnabled>false</IntegratedMerchantCreditCardEnabled>" & @CRLF & _
" <ConditionID>1000</ConditionID>" & @CRLF & _
" <ConditionDisplayName>Brand New</ConditionDisplayName>" & @CRLF & _
" </Item>" & @CRLF & _
" <TransactionArray>" & @CRLF & _
" <Transaction>" & @CRLF & _
" <AmountPaid currencyID="AUD">26.74</AmountPaid>" & @CRLF & _
" <AdjustmentAmount currencyID="AUD">0.0</AdjustmentAmount>" & @CRLF & _
" <ConvertedAdjustmentAmount currencyID="AUD">0.0</ConvertedAdjustmentAmount>" & @CRLF & _
" <Buyer>" & @CRLF & _
" <AboutMePage>false</AboutMePage>" & @CRLF & _
" <EIASToken>nY+sHZ2PrBmdj6wVnY+sEZ2PrA2dj6wNloajDJCLqQ6dj6x9nY+seQ==</EIASToken>" & @CRLF & _
" <Email>rany_morcos@hotmail.com</Email>" & @CRLF & _
" <FeedbackScore>72</FeedbackScore>" & @CRLF & _
" <PositiveFeedbackPercent>100.0</PositiveFeedbackPercent>" & @CRLF & _
" <FeedbackPrivate>false</FeedbackPrivate>" & @CRLF & _
" <FeedbackRatingStar>Blue</FeedbackRatingStar>" & @CRLF & _
" <IDVerified>false</IDVerified>" & @CRLF & _
" <eBayGoodStanding>true</eBayGoodStanding>" & @CRLF & _
" <NewUser>false</NewUser>" & @CRLF & _
" <RegistrationDate>2009-09-15T09:57:47.000Z</RegistrationDate>" & @CRLF & _
" <Site>Australia</Site>" & @CRLF & _
" <Status>Confirmed</Status>" & @CRLF & _
" <UserID>ranoon1</UserID>" & @CRLF & _
" <UserIDChanged>false</UserIDChanged>" & @CRLF & _
" <UserIDLastChanged>2009-09-15T09:57:46.000Z</UserIDLastChanged>" & @CRLF & _
" <VATStatus>VATTax</VATStatus>" & @CRLF & _
" <BuyerInfo>" & @CRLF & _
" <ShippingAddress>" & @CRLF & _
" <Name>Rany Morcos</Name>" & @CRLF & _
" <Street1>6/303 maroondah highway</Street1>" & @CRLF & _
" <CityName>Croydon North</CityName>" & @CRLF & _
" <StateOrProvince>Victoria</StateOrProvince>" & @CRLF & _
" <Country>AU</Country>" & @CRLF & _
" <CountryName>Australia</CountryName>" & @CRLF & _
" <Phone>0450076244</Phone>" & @CRLF & _
" <PostalCode>3136</PostalCode>" & @CRLF & _
" <AddressID>6616753013013</AddressID>" & @CRLF & _
" <AddressOwner>eBay</AddressOwner>" & @CRLF & _
" <AddressUsage>DefaultShipping</AddressUsage>" & @CRLF & _
" </ShippingAddress>" & @CRLF & _
" </BuyerInfo>" & @CRLF & _
" <UserAnonymized>false</UserAnonymized>" & @CRLF & _
" <StaticAlias>ranoon_dy3756phf@members.ebay.com.au</StaticAlias>" & @CRLF & _
" </Buyer>" & @CRLF & _
" <ShippingDetails>" & @CRLF & _
" <ChangePaymentInstructions>true</ChangePaymentInstructions>" & @CRLF & _
" <PaymentEdited>true</PaymentEdited>" & @CRLF & _
" <PaymentInstructions>Methods of payment we accept:1. All major Credit Cards through Paypal.</PaymentInstructions>" & @CRLF & _
" <SalesTax>" & @CRLF & _
" <SalesTaxPercent>0.0</SalesTaxPercent>" & @CRLF & _
" <ShippingIncludedInTax>false</ShippingIncludedInTax>" & @CRLF & _
" <SalesTaxAmount currencyID="AUD">0.0</SalesTaxAmount>" & @CRLF & _
" </SalesTax>" & @CRLF & _
" <ShippingServiceOptions>" & @CRLF & _
" <ShippingService>AU_Regular</ShippingService>" & @CRLF & _
" <ShippingServiceCost currencyID="AUD">0.0</ShippingServiceCost>" & @CRLF & _
" <ShippingServiceAdditionalCost currencyID="AUD">0.0</ShippingServiceAdditionalCost>" & @CRLF & _
" <ShippingServicePriority>1</ShippingServicePriority>" & @CRLF & _
" <ExpeditedService>false</ExpeditedService>" & @CRLF & _
" <ShippingTimeMin>2</ShippingTimeMin>" & @CRLF & _
" <ShippingTimeMax>6</ShippingTimeMax>" & @CRLF & _
" </ShippingServiceOptions>" & @CRLF & _
" <ShippingServiceOptions>" & @CRLF & _
" <ShippingService>AU_RegularParcelWithTracking</ShippingService>" & @CRLF & _
" <ShippingServiceCost currencyID="AUD">2.0</ShippingServiceCost>" & @CRLF & _
" <ShippingServiceAdditionalCost currencyID="AUD">0.0</ShippingServiceAdditionalCost>" & @CRLF & _
" <ShippingServicePriority>2</ShippingServicePriority>" & @CRLF & _
" <ExpeditedService>false</ExpeditedService>" & @CRLF & _
" <ShippingTimeMin>2</ShippingTimeMin>" & @CRLF & _
" <ShippingTimeMax>6</ShippingTimeMax>" & @CRLF & _
" </ShippingServiceOptions>" & @CRLF & _
" <ShippingServiceOptions>" & @CRLF & _
" <ShippingService>AU_Express</ShippingService>" & @CRLF & _
" <ShippingServiceCost currencyID="AUD">100.0</ShippingServiceCost>" & @CRLF & _
" <ShippingServiceAdditionalCost currencyID="AUD">0.0</ShippingServiceAdditionalCost>" & @CRLF & _
" <ShippingServicePriority>3</ShippingServicePriority>" & @CRLF & _
" <ExpeditedService>true</ExpeditedService>" & @CRLF & _
" <ShippingTimeMin>1</ShippingTimeMin>" & @CRLF & _
" <ShippingTimeMax>3</ShippingTimeMax>" & @CRLF & _
" </ShippingServiceOptions>" & @CRLF & _
" <InternationalShippingServiceOption>" & @CRLF & _
" <ShippingService>AU_AirMailInternational</ShippingService>" & @CRLF & _
" <ShippingServiceCost currencyID="AUD">25.0</ShippingServiceCost>" & @CRLF & _
" <ShippingServiceAdditionalCost currencyID="AUD">0.0</ShippingServiceAdditionalCost>" & @CRLF & _
" <ShippingServicePriority>1</ShippingServicePriority>" & @CRLF & _
" <ShipToLocation>NZ</ShipToLocation>" & @CRLF & _
" </InternationalShippingServiceOption>" & @CRLF & _
" <ShippingType>Flat</ShippingType>" & @CRLF & _
" <SellingManagerSalesRecordNumber>59381</SellingManagerSalesRecordNumber>" & @CRLF & _
" <ThirdPartyCheckout>false</ThirdPartyCheckout>" & @CRLF & _
" <TaxTable/>" & @CRLF & _
" <GetItFast>false</GetItFast>" & @CRLF & _
" <ExcludeShipToLocation>Africa</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>Asia</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>Central America and Caribbean</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>Europe</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>Middle East</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>North America</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>Southeast Asia</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>South America</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>AS</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>CK</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>FJ</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>PF</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>GU</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>KI</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>MH</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>FM</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>NR</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>NC</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>NU</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>PW</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>PG</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>SB</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>TO</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>TV</ExcludeShipToLocation>" & @CRLF & _
" <ExcludeShipToLocation>VU</ExcludeShipToLocation>" & @CRLF & _
" </ShippingDetails>" & @CRLF & _
" <ConvertedAmountPaid currencyID="AUD">26.74</ConvertedAmountPaid>" & @CRLF & _
" <ConvertedTransactionPrice currencyID="AUD">24.74</ConvertedTransactionPrice>" & @CRLF & _
" <CreatedDate>2018-11-06T07:13:02.000Z</CreatedDate>" & @CRLF & _
" <DepositType>None</DepositType>" & @CRLF & _
" <QuantityPurchased>1</QuantityPurchased>" & @CRLF & _
" <Status>" & @CRLF & _
" <eBayPaymentStatus>NoPaymentFailure</eBayPaymentStatus>" & @CRLF & _
" <CheckoutStatus>CheckoutComplete</CheckoutStatus>" & @CRLF & _
" <LastTimeModified>2018-11-06T07:14:01.000Z</LastTimeModified>" & @CRLF & _
" <PaymentMethodUsed>PayPal</PaymentMethodUsed>" & @CRLF & _
" <CompleteStatus>Complete</CompleteStatus>" & @CRLF & _
" <BuyerSelectedShipping>true</BuyerSelectedShipping>" & @CRLF & _
" <PaymentHoldStatus>None</PaymentHoldStatus>" & @CRLF & _
" <IntegratedMerchantCreditCardEnabled>false</IntegratedMerchantCreditCardEnabled>" & @CRLF & _
" </Status>" & @CRLF & _
" <TransactionID>2160627739012</TransactionID>" & @CRLF & _
" <TransactionPrice currencyID="AUD">24.74</TransactionPrice>" & @CRLF & _
" <BestOfferSale>false</BestOfferSale>" & @CRLF & _
" <ExternalTransaction>" & @CRLF & _
" <ExternalTransactionID>7E2132560L3706829</ExternalTransactionID>" & @CRLF & _
" <ExternalTransactionTime>2018-11-06T07:14:00.000Z</ExternalTransactionTime>" & @CRLF & _
" <FeeOrCreditAmount currencyID="AUD">0.59</FeeOrCreditAmount>" & @CRLF & _
" <PaymentOrRefundAmount currencyID="AUD">26.74</PaymentOrRefundAmount>" & @CRLF & _
" <ExternalTransactionStatus>Succeeded</ExternalTransactionStatus>" & @CRLF & _
" </ExternalTransaction>" & @CRLF & _
" <ShippingServiceSelected>" & @CRLF & _
" <ShippingService>AU_RegularParcelWithTracking</ShippingService>" & @CRLF & _
" <ShippingServiceCost currencyID="AUD">2.0</ShippingServiceCost>" & @CRLF & _
" </ShippingServiceSelected>" & @CRLF & _
" <BuyerMessage>oz-sunshine@elifeonline.com.au</BuyerMessage>" & @CRLF & _
" <PaidTime>2018-11-06T07:14:01.000Z</PaidTime>" & @CRLF & _
" <ContainingOrder>" & @CRLF & _
" <OrderID>222203266767-2160627739012</OrderID>" & @CRLF & _
" <OrderStatus>Completed</OrderStatus>" & @CRLF & _
" </ContainingOrder>" & @CRLF & _
" <FinalValueFee currencyID="AUD">1.58</FinalValueFee>" & @CRLF & _
" <TransactionSiteID>Australia</TransactionSiteID>" & @CRLF & _
" <Platform>eBay</Platform>" & @CRLF & _
" <PayPalEmailAddress>support@elifeonline.com.au</PayPalEmailAddress>" & @CRLF & _
" <BuyerGuaranteePrice currencyID="AUD">20000.0</BuyerGuaranteePrice>" & @CRLF & _
" <ActualShippingCost currencyID="AUD">2.0</ActualShippingCost>" & @CRLF & _
" <OrderLineItemID>222203266767-2160627739012</OrderLineItemID>" & @CRLF & _
" <IsMultiLegShipping>false</IsMultiLegShipping>" & @CRLF & _
" <IntangibleItem>false</IntangibleItem>" & @CRLF & _
" <MonetaryDetails>" & @CRLF & _
" <Payments>" & @CRLF & _
" <Payment>" & @CRLF & _
" <PaymentStatus>Succeeded</PaymentStatus>" & @CRLF & _
" <Payer type="eBayUser">ranoon1</Payer>" & @CRLF & _
" <Payee type="eBayUser">oz.sunshine</Payee>" & @CRLF & _
" <PaymentTime>2018-11-06T07:14:00.000Z</PaymentTime>" & @CRLF & _
" <PaymentAmount currencyID="AUD">26.74</PaymentAmount>" & @CRLF & _
" <ReferenceID type="ExternalTransactionID">7E2132560L3706829</ReferenceID>" & @CRLF & _
" <FeeOrCreditAmount currencyID="AUD">0.59</FeeOrCreditAmount>" & @CRLF & _
" </Payment>" & @CRLF & _
" </Payments>" & @CRLF & _
" </MonetaryDetails>" & @CRLF & _
" </Transaction>" & @CRLF & _
" </TransactionArray>" & @CRLF & _
" <PayPalPreferred>false</PayPalPreferred>" & @CRLF & _
" </GetItemTransactionsResponse>" & @CRLF & _
" </soapenv:Body>" & @CRLF & _
"</soapenv:Envelope>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")