package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(\.\d+)?((E|e)(\+|-)?\d+)?$`)
var str = `123.5e0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}