package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(for)\s+\w+\s+(in)\s+\w+`)
var str = `for xn in object
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}