package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\|]{0,}((PEPE)[^\|]+(JUAN))[^\|]{0,}\|?`)
var str = `aaaPEPExxxxxJUANaaaaa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}