$re = '/^([0-9A-F]{2}-){5}[0-9A-F]{2}$/m';
$str = '00-1B-63-84-45-E6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);