#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[a-zA-Z0-9]+([\-]?)+([\._]?[a-zA-Z0-9\-])+([\._]?)*([a-zA-Z0-9])@[a-zA-Z0-9\-]([\._]?[a-zA-Z0-9\-])*(\.\w{2,3})+$"
Local $sString = "i_s-.o.--m_e@gmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")