$re = '/(?:\b)([0-9a-f]{8})(?:\b)/i';
$str = '89efd109-89210def
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);