use strict;
my $str = '"ajdojsd \'adas\'"
\'adaodpkosad" "\'
\'hello\' ';
my $regex = qr/^(?:\"([^\"]*)\")|(?:\'([^\']*)\')$/mp;
my $subst = '$1peter file$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";