$re = '/^(?:\d{22}|)(\d{12})$/m';
$str = '1234567890123456789012780467098783';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);