const regex = /^CitrixReceiver\/(0*[1-9]\d\d|0*[2-9]\d|0*19\.0*[1-9]\d\d|0*19\.0*[1-9]\d\d|0*19\.0*[2-9]\d|0*19\.0*1[2-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^CitrixReceiver\\\/(0*[1-9]\\d\\d|0*[2-9]\\d|0*19\\.0*[1-9]\\d\\d|0*19\\.0*[1-9]\\d\\d|0*19\\.0*[2-9]\\d|0*19\\.0*1[2-9])', 'gm')
const str = `CitrixReceiver/0.0.0.0
CitrixReceiver/9999.9999.0.0
CitrixReceiver/19.12.0.0
CitrixReceiver/18.9876.1234.1111
CitrixReceiver/19.12.999.9999
CitrixReceiver/19.100.999.9999
CitrixReceiver/19.000100.999.9999
CitrixReceiver/00019.00012.0000.0000
CitrixReceiver/0019.0012.00999.009999
CitrixReceiver/20.0.0.0
CitrixReceiver/1.2.3.4
CitrixReceiver/19.13.3.4
CitrixReceiver/00019.2.3.4
CitrixReceiver/000100.2.3.4
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}