$re = '/(?<train>((<\[[^a-zA-Z0-9]*\]\.){1})((\.\[[a-zA-Z0-9]*\]\.))*)$/mA';
$str = '<[@].
<[)$-{,]..[PB1N]..[R757G].
<[]..[]..[10]..[223F]..[GBM4].
<[!]..[]
<[)_]..[3N]..[TS]..[0NS58].
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);