$re = '/([\p{L}\s]+)\s-.+:([\d\/]*)/u';
$str = 'Lý Nguyễn Hoàng Ân - Ngày sinh:05/09/2001';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);