re = /https?:\/\/(?:www\.)?audiomack\.com\/(?:song\/|(?=.+\/song\/))(?P<id>[\w\/-]+)/m
str = 'http://www.audiomack.com/song/roosh-williams/extraordinary
http://www.audiomack.com/song/hip-hop-daily/black-mamba-freestyle'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end