#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\]<>%!~"§$#%*&/|\\+()=?{}[$]|[0-9]"
Local $sString = "!" & @CRLF & _
""" & @CRLF & _
"§" & @CRLF & _
"$" & @CRLF & _
"%" & @CRLF & _
"&" & @CRLF & _
"/" & @CRLF & _
"(" & @CRLF & _
")" & @CRLF & _
"=" & @CRLF & _
"?" & @CRLF & _
"{" & @CRLF & _
"}" & @CRLF & _
"[" & @CRLF & _
"]" & @CRLF & _
"\" & @CRLF & _
"#" & @CRLF & _
"*" & @CRLF & _
"+" & @CRLF & _
"~" & @CRLF & _
"<" & @CRLF & _
">" & @CRLF & _
"|" & @CRLF & _
"dccdr cdvfvtg" & @CRLF & _
"12748168345648065486974654600" & @CRLF & _
"dsdshvbds"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")